TP-LINK TL-WR1043ND 刷入 OpenWRT & OpenvSwitch & OpenFlow 1.3

标题挺唬人,其实是一码子事。之前一直没有刷成,可能有下面几个原因:

  • 选择的是OpenWRT开发版。开发版可能并不是很稳定,导致编译的时候一直出错。这次选用了稳定版的15.05.1,编译时候一次过,并没有任何问题。
  • 内核太旧。这个应该是OpenWRT最近更新了内核,然后随之而来的便是自带的OpenvSwitch更新到了2.5.0,这一下子解决了我很多问题。

传统的自己编译的方法请参考:

将OpenFlow 1.3编译进OpenWRT并刷入TP-LINK TL-WR1043ND v3

接下来就说一下如何成功的刷入标题所述的三样东西。

问题解决

之前由于使用了trunk版本进行编译,安装OpenvSwitch的时候一直提示下面问题:

Installing kmod-video-uvc (3.3.8-1) to root…
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/kmod-video-uvc_3.3.8-1_ar71xx.ipk.
Collected errors:
satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-video-uvc:
kernel (= 3.3.8-1-8f454fe85d4baa76feb1ce58fe464f80) * kernel (=3.3.8-1-8f454fe85d4baa76feb1ce58fe464f80) * kernel (=3.3.8-1-8f454fe85d4baa76feb1ce58fe464f80) * kernel (=3.3.8-1-8f454fe85d4baa76feb1ce58fe464f80) * kernel (=3.3.8-1-8f454fe85d4baa76feb1ce58fe464f80) *
opkg_install_cmd: Cannot install package kmod-video-uvc.

网上搜了一下,发现很多人都有类似问题,不过口径都很统一,基本都是楼主在喊,我遇到了这个问题,怎么办怎么办,楼下一群人回复说,我也遇到了我也遇到了,怎么办怎么办。很少看到有人提出解决方案。

最后看到这么两篇文章,可供参考:

  1. Opkg 内核不正确
  2. OpenWrt一些小问题的解决方法

解决办法很简单,就是升级你的OpenWRT版本,因为opkg安装package的时候读取的是最新的列表,而你的OpenWRT版本是旧的,自然会发生内核太旧的这种问题,所以把你的OpenWRT升级到官方支持的最新版本即可。

下载OpenWRT

前往官方的主页,下载对应版本的OpenWRT即可。

Table of Hardware

刷入路由器

可参考前一篇文章:《 将OpenFlow 1.3编译进OpenWRT并刷入TP-LINK TL-WR1043ND v3

安装OpenvSwitch

opkg update
opkg install openvswitch

安装其他组件

opkg install luci

设置密码

passwd

参考文献

“TP-LINK TL-WR1043ND 刷入 OpenWRT & OpenvSwitch & OpenFlow 1.3”的4个回复

  1. 您好 :

    因為15.05.1版本的openwrt內核已是3.18,
    我有先執行opkg update,
    但opkg install openvswitch的版本(2.3)仍舊不支援,
    想請問您,如何編入openvswitch 2.5.0版?

    謝謝!

    1. 您好,照理说opkg install的就该是2.5.0的版本,不知道你这个为什么会是2.3的,你可以尝试直接编译openvswitch到安装包试试。

发表评论

电子邮件地址不会被公开。 必填项已用*标注